演示:RIP路由更新的毛病剖析与扫除51CTO博客 - 众发娱乐

演示:RIP路由更新的毛病剖析与扫除51CTO博客

2019年03月04日09时46分43秒 | 作者: 半梅 | 标签: 毛病,路由,更新 | 浏览: 1647

演示:RIP路由更新的毛病剖析与扫除


毛病布景:如图14.6所示的网络环境,工程师在相应的接口装备了接口地址,并在整个网络发动了RIP路由协议,由于一些特别原因在路由器S2/0的接口上没有装备详细的IP地址,运用了无编号IP地址(ipunnumbered e1/0),现实上S2/0接口上的IP地址是向E1/0接口借的,在实践的出产环境中,发生这种无编号IP地址的原因是为了在点对点的链路上节约IP地址,避免地址糟蹋,所以这种应用是合法的。然后为了某些安全特性,工程师在路由器R1的E1/0接口的入方向上装备了ACL列表,只答应源地址为192.168.3.1、源子网为192.168.6.0/24的子网拜访恣意网络,其他的流量被ACL101躲藏的Deny句子所回绝。当完结上述的装备后,现在呈现了一个现象:路由器R1无法学到任何路由如图14.7所示;R2路由学习彻底正常如图14.8所示;R3也无法学习到任何路由如图14.9所示。

现在请剖析呈现这些毛病的原因,并在不改动原有装备的状况扫除毛病。


发生毛病的原始装备:发生毛病的原始装备如下所示。


路由器R1的原始装备:

interface Loopback1

ip address 192.168.5.1 255.255.255.0

!

interfaceEthernet1/0

ip address 192.168.2.1 255.255.255.0

ip access-group 101 in

duplex half

!

router rip

version 2

network 192.168.2.0

network 192.168.5.0

no auto-summary


access-list 101permit ip host 192.168.3.1 any

access-list 101permit ip 192.168.6.0 0.0.0.255 any


路由器R2的原始装备:

interfaceEthernet1/0

ip address 192.168.2.2 255.255.255.0

duplex half

!

interface Serial2/0

ip unnumbered Ethernet1/0

encapsulation ppp

!

routerrip

version 2

network 192.168.2.0

no auto-summary


路由器R3的原始装备:

interface Loopback1

ip address 192.168.6.1 255.255.255.0

!

interface Serial2/0

ip address 192.168.3.2 255.255.255.252

encapsulation ppp

!

router rip

version 2

network 192.168.3.0

network 192.168.6.0

no auto-summary


毛病剖析:在现实的作业环境中,有时遇到的毛病,一般不在一处,比方:这个毛病就发生在路由器R1和R3上,刚好中心的路由器R2作业正常,当遇到这种复合型毛病时,请首先将分而治之,进行独立剖析,这样能够减小毛病堆叠后的扫除规模,留意这将是一个非常好的主张。所以现在首先在路由器R3上,运用debug ip rip events指令来调试RIP的作业进程,这样能够看到RIP在后台作业的数据包,得到如图14.10所示,指示路由器R3的S2/0的接口收到一个坏的RIP的数据包,发送一个坏的RIP数据包的源地址是192.168.2.2现实上就是路由器R2的S2/0接口,由于路由器R2的S2/0接口是向E1/0借的IP地址,而发生这个毛病的原因是路由器R2的S2/0运用了无编号IP地址(ip unnumbered),而路由器R3的S2/0接口运用了详细的IP地址,在这种状况下,路由器R3会检测更新源的合法性,有必要要求路由器R2的路由更新源地址与自己的S2/0接口上的IP地址在同一个子网,不然路由器R3会陈述收到坏的路由更新,处理这个毛病有两种计划:一是为路由器R2的S2/0的接口装备一个与路由器R3的S2/0接口相同子网的详细IP地址,但这种处理计划损坏了原有的地址规划,改动了原有装备,由于在许多状况下进行毛病扫除时,是以不损坏设备原有装备为准则。第二个处理计划就是封闭路由器R3上关于RIP更新源合法性检测的功用,默许状况下这个功用是被发动的,详细的扫除进程请参看处理计划部分,当完结这个行为后,能够看到路由器R3的路由学习正常,路由表成功学到了R2发来的路由更新,如图14.12所示。现在现已成功处理路由器R3的路由毛病。

在路由器R1的装备看上去好像很合理,由于在ACL中答应了RIP网络中的一切长途子网抵达路由器R1。在这种状况下,仍是首先在路由器R1上运用debug ip rip event指令检查RIP更新的状况,如图14.11所示,指示路由器R1没有收到任何来自路由器R2的路由更新,假如物理链路正常而且确保RIP的装备正常,那么就是ACL的躲藏的Deny句子回绝了方针地址是224.0.0.9的RIP更新组播地址,这将导致RIP的路由更新失利,处理计划是在路由器R1现有的ACL中参加一条答应方针地址224.0.0.9的组播地址抵达路由器R1,

    详细的扫除进程请参看处理计划部分,当完结这个行为后,能够看到路由器R1的路由学习正常,如图14.13所示。毛病成功扫除。

处理计划:

R3(config)#router rip

R3(config-router)#no validate-update-source* 封闭RIP更新源合法性检测。

R3(config-router)#exit


R1(config)#access-list 101 permit ip any host 224.0.0.9

* 添加答应RIP更新组播经过的ACL条目。



版权声明
本文来源于网络,版权归原作者所有,其内容与观点不代表众发娱乐立场。转载文章仅为传播更有价值的信息,如采编人员采编有误或者版权原因,请与我们联系,我们核实后立即修改或删除。

猜您喜欢的文章