CCIE实验备考之冗余备份(IRDP)51CTO博客 - 众发娱乐

CCIE实验备考之冗余备份(IRDP)51CTO博客

2019年02月18日10时34分49秒 | 作者: 子辰 | 标签: 路由器,备份,布告 | 浏览: 2297

冗余备份特性
能够供给冗余备份的机制:
1. IRDP,ICMP Router Discovery Protocol(ICMP路由发现协议)
2. HSRP,Hot Standby Router Potocol(热备份路由协议)
3. VRRP,Virtual Router Redundancy Potocol(虚拟路由冗余协议)
4. GLBP,Gateway Load Balancing Protocol(网关负载协议)
5. Cisco-SLB,Cisco Server Load Balancing   榜首部分 IRDP
在ICMP路由器发现协议IRDP中,支撑IRDP的主机会动态地发现用于拜访非本地网络的路由器。IRDP支撑主机发现路由器。路由器发现数据包会在主机(IRDP服务器)和cisco路由器(IRDP客户端)之间交流。软件还会偷听RIP和IGRP路由更新,并从更新中推断出路由器的方位,而主机并不会真实的查看和存储路由设备宣布的完好的路由表,仅仅记录下来哪些体系在发送这样的数据罢了。
在运用一组cisco路由器的LAN网段中,能够恣意组合装备RIP、IGRP和IRDP3种协议。Cisco引荐尽可能地运用IRDP,以为他支撑设定每台路由器的优先级和超时时刻。
经过发现的每台设备都会成为候选的缺省网关,然后对候选表进行扫描,并在下列3种情况下挑选一个新的优先级最高的路由器:
1) 当发现了比当时缺省路由器优先级最高的路由器时(每5分钟扫描一次候选路由表)
2) 以为当时路由器呈现了毛病时
3) 因为很多的重传,某个TCP衔接操时,IRDP会清空ARP缓存和ICMP重定向缓存的内容,并在查找抵达意图端的路由时运用新的缺省路由器
运转IRDP时,主机会参加“悉数设备”IP组播组(224.0.0.1)并开端监听IRDP客户端(路由器)发送该组的路由器布告。为了削减接口初始化的推迟时,主机也能够发送路由器恳求音讯到”悉数路由器”IP组播地址(224.0.0.2),路由器会宣布“路由器布告”进行呼应,确保了主机能当即发现缺省网关。
布告每隔7-10分钟发送一次,而默许的生命周期为30分钟。IRDP有两个独立的时刻距离:最小的和最大的布告距离。一切自动供给的布告的发送距离都在这两个值指定的规模之内。
装备办法:
榜首步:接口形式下使能IRDP
        ip irdp
第二步:指定优先等级
        ip irdp preference 优先等级
        缺省的优先等级为0,值越大优先等级越高
其他装备:
A) 通常情况下,对布告是进行播送,要让IRDP运用到224.0.0.1的组播来替代播送,能够运用指令:接口形式下
    ip irdp multicast
B) 修正生命周期holdtime
    ip irdp holdtime 秒数
    秒数为4-9000,默以为1800秒,30分钟
C) 修正最大布告时刻
     ip irdp maxadvertinterval 秒数
     秒数为4-1800秒,默以为600秒
D) 修正最小布告时刻
     ip irdp minadvertinterval 秒数
     秒数为3-1800秒,默以为450秒
事例:
R1#config termi
R1(config)#int e0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#ip irdp preference 2147483647
R1(config-if)#no shut
R1#show ip irdp e0
Ethernet0 has router discovery enabled
Advertisements will occur between every 450 and 600 seconds.
Advertisements are sent with broadcasts.
Advertisements are valid for 1800 seconds.
Default preference will be 2147483647.

R2(config)#inter e0
R2(config-if)#ip addr 192.168.1.2 255.255.255.0
R2(config-if)#ip irdp preference -2147483647
R2(config-if)#no shut r2#show ip irdp e0
Ethernet0 has router discovery enabled
Advertisements will occur between every 450 and 600 seconds.
Advertisements are sent with broadcasts.
Advertisements are valid for 1800 seconds.
Default preference will be -2147483647.
-
咱们运用R3作为一个dhcp服务器,装备两个默许网关
r3(config)#ip dhcp pool cisco
r3(dhcp-config)#network 192.168.1.0 255.255.255.0
r3(dhcp-config)#default-router 192.l168.1.1 192.168.1.2
-
路由器4作为客户端进行检测
r4(config)#interface e0
r4(config-if)#ip address dhcp
-
咱们模拟将r1中止
r4检测
*Mar  1 09:46:43.421: ICMP: rdp advert rcvd type 9, code 0, from 192.168.1.2
*Mar  1 09:47:01.421: ICMP: rdp advert rcvd type 9, code 0, from 192.168.1.2
*Mar  1 09:47:15.421: ICMP: rdp advert rcvd type 9, code 0, from 192.168.1.2
*Mar  1 09:47:34.421: ICMP: rdp advert rcvd type 9, code 0, from 192.168.1.2
r2上
*Mar  1 05:03:58.378: ICMP: src=192.168.1.2, dst=255.255.255.255, irdp advertisement sent
*Mar  1 05:03:58.382: IRDP: entries=1, size=2, lifetime=30, bytes=36
*Mar  1 05:03:58.382: IRDP: address=192.168.1.2 preference=0
事例:
CCIE-LAB(V142)
标题要求:
在VLANC上的主机不想装备第二个网关,不允许运用HSRP,使得VLANC的主机优选R6的E0端口地址为首选网关,其次选R5的Fa0/0端口地址为最终网关。
VLAN C   R5-F0/0    R6-EO
装备:
R6
   configure terminal
   interface e0
ip irdp
ip irdp preference 2147483647
R5
   configure terminal
   interface f0/0
ip irdp
ip irdp preference -2147483647
版权声明
本文来源于网络,版权归原作者所有,其内容与观点不代表众发娱乐立场。转载文章仅为传播更有价值的信息,如采编人员采编有误或者版权原因,请与我们联系,我们核实后立即修改或删除。

猜您喜欢的文章